由于版本兼容问题,无法直接通过windows server2012/2016的服务器管理工具安装.net framework 3.5,只能通过挂载windows server 2012或者 2016的安装包,将安装目录指定为安装包中的sxs的目录才能正常安装!

因此如果您的系统是2012或者2016,而且需要安装sql server2012及以上版本的话,就同时下载个您的系统对应的安装包,然后挂载到虚拟光驱中,然后安装即可,图示如下:

1、参考前面安装IIS的图示到这个步骤,选择指定备用源路径

2、路径位置输入正确的sources\sxs路径

至于下载安装包的方法就自己去研究了,如果有安装盘,直接放到光驱即可,如果没有就网上搜索msdn itellyou就能找到了